'rhythm reading' ignores midi input

Need technical advice? Don't know where to find an option? Here is the right place to ask.

Moderator: Quentin

User avatar
dave007
Ear training rookie
Posts: 2
Joined: Jul 10, 2017 7:28 pm

'rhythm reading' ignores midi input

Postby dave007 » Jul 10, 2017 7:40 pm

hello,

i'm trying to do the 'rhythm reading' exercises. when i click on the red baton with the mouse, it works fine. however, when i try to enter the notes using my midi keyboard, the program acts as if i haven't hit any keys at all.

i've made sure that the 'midi in' box in 'answer input' is checked. [indeed, i can answer exercises in the 'chord identification' exercises w/o problems.]

when i run the windows midi monitor application, i can see that the notes transmitted from my midi keyboard are entering my computer. i can also change the channels the notes are being sent to, and that works correctly. however, earmaster doesn't respond to notes sent on any of the 16 channels.

any ideas what i'm doing wrong ?

thanks much in advance.

--
system information --
- windows xp professional sp3
- earmaster essential 5 build 639ew

User avatar
Quentin
EarMaster.com
Posts: 1916
Joined: Apr 27, 2007 1:25 am
Location: Denmark
Contact:

Re: 'rhythm reading' ignores midi input

Postby Quentin » Jul 11, 2017 5:05 am

Hi,
Is MIDI In turned on also for that exercise? That option is set for each activity independently. So turning it on in Interval Identification doesn't mean it is also turned on in rhythm reading. To make sure it is turned on, look at the MIDI toggle at the top right of the exercise window. A green dot should light up each time you press a note on your MIDI keyboard. If it's not the case, then try clicking on the MIDI icon. Is that solving the problem?
- Because in Music, We're All Ears... -

User avatar
dave007
Ear training rookie
Posts: 2
Joined: Jul 10, 2017 7:28 pm

Re: 'rhythm reading' ignores midi input

Postby dave007 » Jul 11, 2017 3:50 pm

thanks for your reply, quentin.

it turned out to be a problem with the software 'connection' to the keyboard. i had turned off the keyboard and turned it back on [for some reasons unrelated to the earmaster software], and later changed from chord recognition to rhythm reading in earmaster. when you mentioned the 'green dot', i took a look and noticed that it wasn't 'lighting' even though the windows midi monitor showed midi input to the machine, so i went into earmaster's tools=>midi devices, chose a different input, and then did the same thing once again, this time re-selecting my keyboard. that fixed the problem, i'm guessing by somehow 'reconnecting' the software to the windows midi driver.

thanks much for your help.

User avatar
Quentin
EarMaster.com
Posts: 1916
Joined: Apr 27, 2007 1:25 am
Location: Denmark
Contact:

Re: 'rhythm reading' ignores midi input

Postby Quentin » Jul 12, 2017 1:15 am

Glad you got it to work. :)
Please always make sure that your MIDI keyboard is plugged in prior to starting EarMaster, as the software isn't automatically adding MIDI devices after it has been started up. It only scans your system for MIDI devices when starting up.
- Because in Music, We're All Ears... -


Who is online

Users browsing this forum: No registered users and 12 guests