Latency Problem during Rhythm Exercises

Need technical advice? Don't know where to find an option? Here is the right place to ask.

Moderator: Quentin

User avatar
Ear training freshman
Posts: 1
Joined: Feb 27, 2021 7:48 am

Latency Problem during Rhythm Exercises

Postby Ricky » Feb 27, 2021 8:04 am

Hi there,

I have recently purchased Earmaster 7 and started to work through some exercises. Much to my surprise I never get the rhythm exercises right, it seems I am way behind the beat. When I switched off the silent input I realized that there is a huge latency between me pressing the space bar/ downward arrow / mouse button/ midi keyboard until earmaster plays back a sound. This is also evident from watching the hands clap on the screen, takes ages from actually pushing the button until something happens. I didn't find any options to further optimize buffer sizes or else. It is definitely not my laptop, other applications like Amplitube or other amp simulations run without any noticeable latency.
My setup is as follows:
MS Windows 10 professional
Intel Core I7-7500U 2.7 GHz
Focusrite Scarlett 2i2

Pretty disappointing, can you help me out?

User avatar
Posts: 2202
Joined: Apr 27, 2007 1:25 am
Location: Denmark

Re: Latency Problem during Rhythm Exercises

Postby Quentin » Mar 01, 2021 6:49 am

Hi Ricky,

In EarMaster, input latency and output latency are not linked. SO even if you experience a big latency of the audio playback, it is not the same latency as that of the input.

In EarMaster's preferences, you will find a "Latency compensation-->Input timing offset" option under Other Options. It is set to 40ms by default, but you can try to set it to 100ms or 120ms for example and see if that helps. If it's too much, you can roll it back a little. It will however be necessary to re-enable "Silent Input", as there is no latency compensation tool for audio playback in EarMaster 7.
- Because in Music, We're All Ears... -

Who is online

Users browsing this forum: No registered users and 14 guests