Spacebar tapping inaccurate in rhythm sight reading

Discuss EarMaster, ear training, theory or music in general, ask questions and share your experience.

Moderator: Quentin

User avatar
empauly
Ear training ninja
Posts: 26
Joined: Feb 25, 2014 9:42 am

Spacebar tapping inaccurate in rhythm sight reading

Postby empauly » Oct 08, 2020 6:39 pm

Hi Quentin,

I have received feedback from students that the rhythm sight playing exercises don't always work well with their computers. I tested out a few things tonight in the Beginner's Course just to check.

Here is what I am finding: (On a MacBook Pro, 2019, 10.15.6)

If I tap and hold the space bar (to indicate playing a rhythm at full value), Earmaster often reads this as a double-tap. If I don't hold the space bar, Earmaster tells me that my rhythms are accurate, but that I am not holding the note values long enough.

Lag is a bit of an issue as well (and some of my students have mentioned this too).

I don't know what other operating systems are experiencing this problem.

If you have tips for settings changes, or ways that we can make this less frustrating for students, I would love to know.
Thanks,
Liz

User avatar
Quentin
EarMaster.com
Posts: 2188
Joined: Apr 27, 2007 1:25 am
Location: Denmark
Contact:

Re: Spacebar tapping inaccurate in rhythm sight reading

Postby Quentin » Oct 09, 2020 2:35 am

Hi Liz,

Good to hear from you again :)

A problem with double hits with the space bar rings a bell. I think it used to be a issue some months ago. Could you please make sure that you are using the latest build. To do that, open the HELP menu and click on "Check for updates". If an update is available, please download it and install it. If the problem persists, could you please send us a video showing th eissue so that we may try to reproduce it here on our end?

Issues with latency usually have to do with the sound playback engine on the computer. Since it often is an issue, EarMaster now activates its "Silent input" option by default so that no sound is played when you perform the rhythms on the space bar, the downward arrow key or the mouse buttons. But if you have been using EarMaster for some time, that option won't be changed and you have to do it manually via the Exercise Options (the right-side option panel in the exercises) by switching "Silent input" ON).
- Because in Music, We're All Ears... -


Who is online

Users browsing this forum: Bing [Bot] and 10 guests