Microphone allowance

Need technical advice? Don't know where to find an option? Here is the right place to ask.

Moderator: Quentin

User avatar
Abletonjazz
Ear training rookie
Posts: 3
Joined: Dec 11, 2020 10:24 am

Microphone allowance

Postby Abletonjazz » Dec 11, 2020 10:43 am

Hey people. I have a problem of which I couldn’t find the solution anywhere so I hope someone can help me here.

Whenever I try to do an exercise it says “Oops! It looks like you didn’t allow EarMaster to use your microphone. To use this exercise, please give EarMaster acces to your microphone from your iOS settings.” It keeps popping up everytime I’m doing an interval or chord inversion so it’s very hindering in completing the ecercise. The problem is: nowhere in my settings I can give this allowance, neither at the microphone settings nor at the EarMaster settings. I have been using the app for months but this happened today for the first time. I tried deleting and redownloading the app but it didn’t help. I’m using an iPhone 6s with iOS version 12.4.1. Does any of you have a clue how I can fix this?

Edit: It's weird because the exercises I'm doing don't even require a microphone.

User avatar
Quentin
EarMaster.com
Posts: 2179
Joined: Apr 27, 2007 1:25 am
Location: Denmark
Contact:

Re: Microphone allowance

Postby Quentin » Dec 14, 2020 1:02 am

Hi,

You're ot doing anything wrong, it's a bug in the latest update and we are fixing it. The solution is to open an exercise that requires Mic input (a sight-singing exercise for example) and allow Mic recording. Then you won't be annoyed by that message again.

The Mic setting in iOS preferences first appear when you have allowed (or blocked) mic recording in the app.

Apologies for the inconvenience.
- Because in Music, We're All Ears... -

User avatar
Abletonjazz
Ear training rookie
Posts: 3
Joined: Dec 11, 2020 10:24 am

Re: Microphone allowance

Postby Abletonjazz » Dec 14, 2020 3:52 am

Thank you for your reply, it worked!


Who is online

Users browsing this forum: No registered users and 13 guests